Rating Engine Monitoring and Troubleshooting
To troubleshoot Rating Engine deployment issues, please go to Deploying Rating Engine.
Resolving Billing Period Rounding Precision Inconsistency Between Rating Engine and Billing
Symptoms
The extended price of an order detail differs from its expected value by a small amount.
Possible Cause
If billing period rounding precision is set differently for Rating Engine and for Billing, it may lead to calculation inconsistencies and disrupt the work of
Solution
To resolve billing period rounding precision inconsistency between Rating Engine and Billing:
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Check the billing period rounding precision settings:
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for Rating Engine: On the Rating Engine POD, check the durationprecision configuration parameter, for example:
# kubectl get pods | grep -i ratingengine ratingengine-5b8897b699-5fcw5 1/1 Running 1 4d21h # kubectl describe pod ratingengine-5b8897b699-5fcw5 | grep -i duration DURATION_PRECISION: 2
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If necessary, adjust the billing period rounding precision settings:
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for Rating Engine: Upgrade the Rating Engine POD to the same version passing a new value of the durationprecision parameter. To keep the other settings unchanged, pass --reuse-values. To keep the same microservice version, pass the installed version number to the --version argument. For example:
# helm list | grep -i ratingengine ratingengine 2 Wed Dec 23 13:43:06 2020 DEPLOYED ratingengine-backend-1.4.1137 default # helm upgrade --reuse-values --set durationprecision=2 --version=1.4.1137 ratingengine a8n/ratingengine-backend